Flash Builder 4.5.1 verfügbar

Erstellt am : June 20, 2011 10:20 PM

Seit heute ist das versprochene Update für den Flash Builder 4.5 und Flex SDK 4.5 erhältlich. So ist es nun möglich mit dem Flash Builder Applikationen für Apple iOS oder RIM Playbook zu erstellen.

Die neue Version kann bei Adobe runtergeladen werden oder wenn der Flash Builder bereits installiert ist kann über den Update nur aktualisiert werden. Ein wenig verwirrend ist, das mit dem Flash Builder aktuell nur AIR 2.6 mitkommt - wurde doch iOS Support mit AIR 2.7 angekündigt. Im Flash Builder 4.5.1 ist nun eine erweiterte AIR 2.6 Version mit dabei und der Packager aus 2.7. Eine iOS Applikation kann somit also nur AIR 2.6 APIs verwenden aber profitiert durch den Packager von der verbesserten Geschwindigkeit.

Damit das erstellen von Mobil Applikationen auch einfach geht hilft der Flash Builder beim erstellen eines solchen Projekts. Es lassen sich nun auch Flex Mobile Projects erstellen. Dabei lässt sich auswählen für welche Platform die App verfügbar sein soll und entsprechend der Platform lassen sich dann noch Rechte oder anderweitige Einstellung machen.

Für einige Applikationen und Spiele wird Flex/AIR sicherlich eine gute Alternative gegenüber der nativen Programmierung für die jeweiligen Geräte. Gerade wenn möglichst viele Platformen bedient werden sollen ist es angenehm damit zu Arbeiten. Allerdings ergibt sich aus der Zwischenschicht von AIR auch einige Nachteile, so lassen sich nicht alle APIs der jeweiligen Platform verwenden. Z.B. sind unter iOS aktuell keine Push Messages oder in App Käufe möglich und noch einiges mehr. Auch wird weiterhin ein Mac benötigt um eine App in den App Store zu stellen, da Apple seit einiger Zeit den Upload der Applikation nur noch über eine Mac Applikation erlaubt.

Flash Builder 4.5.1 Updater
Flash Builder 4.5.1 Release Notes
Flex 4.5.1 SDK
Flex 4.5.1 SDK Release Notes

Kommentare (Kommentar Moderation ist aktiviert. Ihr Eintrag wird erst nach freischaltung sichtbar.)
BlogCFC was created by Raymond Camden. This blog is running version 5.8.001.